Trunking Protocols (Cisco Note)

A trunk port is a type of connection on a switch that is used to connect a guest virtual machine that is VLAN aware. Generally, all frames that flow through this port are VLAN tagged. The exception to this is when a trunk port is granted access to the untagged VLAN set (native VLAN ID).

ISL (Inter-switch Link)

*It’s a Cisco proprietary
*It works with Ethernet, Token ring, FDDI
*It adds 30 bytes of tag
*No more supported on new cisco platforms

IEEE 802.1Q

*IEEE Open standard
*It works only on Ethernet
*Only 4 Byte tag will be added to original frame



Trunk Configuration

Switch(config)# interface<interface type><interface no>
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q

We already created the Vlan 3 and Vlan 4 on both Switch.

SW-1(config)# interface range f0/1-2
SW-1(config-if-range)#switchport mode access
SW-1(config-if-range)#switchport access vlan 3
SW-1(config-if-range)#exit
SW-1(config)#intrface range f0/3-4
SW-1(config-if-range)#switchport mode access
SW-1(config-if-range)#switchport access vlan 4
SW-1(config-if-range)#end
SW-2(config)# interface range f0/1-2
SW-2(config-if-range)#switchport mode access
SW-2(config-if-range)#switchport access vlan 3
SW-2(config-if-range)#exit
SW-2(config)#intrface range f0/3-4
SW-2(config-if-range)#switchport mode access
SW-2(config-if-range)#switchport access vlan 4
SW-2(config-if-range)#end

Configure F0/20 port between SW1 and SW2 as Trunk Link

SW(config)#interface fastEthernet 0/20
SW(config-if)#switchport mode trunk
SW(config-if)#switchport trunk encapsulation dot1q

Leave a Reply

Your email address will not be published.

DigitalOcean Referral Badge